Help with 1993  60 hp  3 cyl  Mercury

Mercury Outboard  general discussion

Help with 1993  60 hp  3 cyl  Mercury

Postby blin10 » Sat May 04, 2019 2:53 am

I need to ID a part I can't find in parts  list.  There are green/White and White/Green wires  out of stator going to one end of box and blue wire going to  19052A8 switch box and black wire going to ground. The parts list have a speed limiter  but its square. I don't have any spark on motor and don't have a DVA tester but I used a O Scope and can see wave form and have about 200 volt Peak to Peak  on the 2 green /white stator wires. and about 20 volts Peak to Peak from the 3 trigger wires. This indicates bad switch box right ?  I have ordered a complete electrical panel with switch box, 3 coils, starter relay, voltage regular reg. , and rectifier.  But the part I want to ID isn't there. I talked to seller and he said 2 yellow a 2 green/white wires cone from Stator.  He can't remember the part I am asking about. He told me he had Spark before he took parts off motor. Do I neen that missing part.  I am a Antique Mercury man but I am trying to help my son.
Attachments
IMG_20190503_203127[1].jpg
blin10
 
6 years of membership6 years of membership6 years of membership6 years of membership6 years of membership6 years of membership
 
Posts: 150
Joined: Mon Oct 28, 2013 1:24 pm
Location: Monticello, Fla.

Re: Help with 1993  60 hp  3 cyl  Mercury

Postby Tom Brockmeyer » Sat May 04, 2019 5:49 pm

That is part of an old 16Amp"red stator" upgrade kit to replace rectifier with regulator/rectifier for that engine...  Looks correct to me as the original Mercury factory replacement parts.  NLA now, so the aftermarket parts are from CDI Electronics.  If you replace it, you'll want the stator & regulator from link below.  PDF files show you the installation sheets.

http://www.cdielectronics.com/cdi-appli ... SearchForm
Lake Lanier, 30miles North of Atlanta, GA
Old Mercury outboard fan... Especially the fast ones!
Mercury/MerCruiser,  Evinrude/Johnson & VolvoPenta Technician (After my suit & tie wearing career was done!)
Tom Brockmeyer
KIDS APBA SPONSOR
 
8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership
 
Posts: 4211
Images: 0
Joined: Mon Jan 31, 2011 10:14 pm

Re: Help with 1993  60 hp  3 cyl  Mercury

Postby blin10 » Sat May 04, 2019 8:03 pm

Maybe I didn't make it clear this part in the photo hooks the green/white from Stator and its output is Blue to Switch box and black to ground. The two yellow leads go to into the regulator.
blin10
 
6 years of membership6 years of membership6 years of membership6 years of membership6 years of membership6 years of membership
 
Posts: 150
Joined: Mon Oct 28, 2013 1:24 pm
Location: Monticello, Fla.

Re: Help with 1993  60 hp  3 cyl  Mercury

Postby Tom Brockmeyer » Sun May 05, 2019 11:48 pm

The long black module in the center of your picture was NOT an original part on your engine. It's an adapter of sorts so the new (red) stator doesn't fry the switchbox (CDI ignition module).  It is part of the red stator upgrade kit, and if you get the instruction sheet for that kit, you should be able to figure out what wiring changes were done when it was installed.  I don't have it, but a dealer or a phone tech support guy at CDI Electronics will surely be able to help you.
Tom
Lake Lanier, 30miles North of Atlanta, GA
Old Mercury outboard fan... Especially the fast ones!
Mercury/MerCruiser,  Evinrude/Johnson & VolvoPenta Technician (After my suit & tie wearing career was done!)
Tom Brockmeyer
KIDS APBA SPONSOR
 
8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership
 
Posts: 4211
Images: 0
Joined: Mon Jan 31, 2011 10:14 pm

Re: Help with 1993  60 hp  3 cyl  Mercury

Postby blin10 » Mon May 06, 2019 12:59 am

OK thanks I wondered why I had a big voltage drop  across the module when I tested the Stator output. I hooked up a new Switch Box today with the module between the switch box and stator and I have spark.

Thanks for info.
blin10
 
6 years of membership6 years of membership6 years of membership6 years of membership6 years of membership6 years of membership
 
Posts: 150
Joined: Mon Oct 28, 2013 1:24 pm
Location: Monticello, Fla.


Return to John's Old Merc "General Forum"

Who is online

Users browsing this forum: No registered users and 1 guest